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Important Information

NOTE: If you own a SMART product other than a SMART Senteo™ interactive response system, 
refer to the user’s guide that came with your product for relevant warnings and maintenance 
instructions.

Before you use the SMART Senteo interactive response system, please read and understand the 
safety warnings and precautions described in this guide. These safety warnings and precautions 
instruct you in the safe and correct operation of the system and its accessories so you can prevent 
injuries to yourself, others or damage to the equipment. You must always ensure that the Senteo 
interactive response system is being used correctly.

Safety Warnings  

WARNING
Failure to follow the installation instructions that ship with the SMART product could 
result in personal injury or damage to the product.

WARNING When using the Senteo interactive response system with a SMART Board™ 
interactive whiteboard and projector, do not stare into the beam of light created by 
the projector. Instruct children not to look in the direction of, or stare at, this beam 
of light. 

WARNING
Ensure that any cables extending across the floor to your SMART product are 
properly bundled and marked to avoid a trip hazard.

WARNING
To reduce the risk of fire or electric shock, do not expose the components to rain or 
moisture.

CAUTION
Use only the batteries provided or equivalent replacements. Do not attempt to 
recharge the batteries.

CAUTION

Do not install batteries with the polarity (+/–) reversed.

CAUTION Do not dispose of batteries in a fire or incinerator.

Dispose of batteries according to the laws and regulations of your region. If you 
don’t know the applicable rules for your region, consult the battery manufacturer.
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Compliance
This device complies with Part 15 of the FCC rules. Operation is subject to the following two 
conditions:

1. This device may not cause harmful interference, and
2. This device must accept any interference received, including interference that may cause 

undesired operation.
Changes or modifications to this equipment not expressly approved by SMART Technologies Inc. 
may void the user’s authority to operate this equipment.

NOTE: This equipment has been tested and found to comply with the limits for a Class B digital 
device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable 
protection against harmful interference in a residential installation.

This equipment generates, uses, and can radiate radio frequency energy and, if not installed and 
used in accordance with the instructions, may cause harmful interference to radio 
communications. However, there is no guarantee that interference will not occur in a particular 
installation. If this equipment does cause harmful interference to radio or television reception, 
which can be determined by turning the equipment off and on, the user is encouraged to try to 
correct the interference by one or more of the following measures:

• Reorient or relocate the receiver or clicker units.
• Increase the separation between the equipment and the product.
• Connect the affected equipment into an outlet on a circuit different from that to which the 

receiver’s computer is connected.
• Consult your SMART service representative or an experienced radio/TV technician for help.

CAUTION

Never use abrasive erasers or harsh chemicals when cleaning Senteo hardware.

CAUTION
Do not open the receiver or clicker units to attempt repairs. Refer all service to 
authorized SMART service personnel.

IMPORTANT You must connect the USB cable that came with your SMART product to a 
computer that has a USB compliant interface and that bears the USB logo. In 
addition, the USB source computer must be compliant with CSA/UL/EN 60950 and 
bear the CE mark and CSA and/or UL Mark(s) for CAS/UL 60950. This is for 
operating safety and to avoid damage to the SMART product.

IMPORTANT
If your SMART product requires replacement parts, make sure the service 
technician uses replacement parts specified by SMART Technologies Inc. or parts 
with the same characteristics as the original.
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About the Senteo Interactive Response System

Overview
The Senteo interactive response system is an assessment tool designed to enhance learning. It 
facilitates summative and formative assessment by allowing you to pose a question before, during 
or after a lesson to find out if students are on track. You can use the feedback to help shape the 
rest of your lesson.

Once you’ve finished the lesson, you can create a question set with senteo software to evaluate 
learning more formally. You can feel confident that the students have answered the way they 
intended because they can verify and change their self-paced responses directly on the remote.

You can easily add creativity to questions by combining text with images to make questions more 
dynamic. The Senteo system comes with Notebook™ collaborative learning software and offers 
6,000 learning objects that can be easily added to quizzes. You can write and edit notes in digital 
ink, import or export Microsoft PowerPoint™ presentations, and incorporate multimedia content.

The Senteo interactive response system increases one-to-one interaction by allowing you to 
survey and engage students and collect responses. You can use student feedback to plan lessons 
and personalize the learning environment. 

Features
• Flexible package 

options
The Senteo interactive response system includes a receiver and 
clickers, and is available in 24- or 32-unit packages. You can also 
purchase receivers individually, and clickers in packs of one and five 
units.

• Cross-platform support You can use Senteo interactive response system with Microsoft 
Windows® and Mac OS operating systems.

• Notebook software 
resources

Use Notebook software objects to build dynamic questions with 
images and other multimedia content.

• Flexible assessment 
options

You can prepare quizzes in advance or ask instant questions.

• Question variety Ask true or false, yes or no, multiple choice, numeric response and 
more-than-one right answer questions. You can also incorporate 
decimals, fractions and negative numbers into questions.

• Instant feedback You can see how well students understand what you’ve taught them 
immediately. You can get feedback in bar graphs or pie charts 
summarizing the results from one question or all of them. You can 
also see responses from individual students.

• Import questions from 
other applications

You can import questions from Microsoft Word or questions in XML 
format. The Senteo system also integrates with PowerPoint 
presentation software.

• Export results You can use the Senteo system to export student answers to an 
Excel spreadsheet or HTML Web page.
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• Print question sets and 
study guides

The Senteo software allows you to print question sets as handouts 
so students can complete them at their own pace. You can also print 
result summaries so each student knows which questions they got 
right or wrong. You can also add teacher comments and use the 
summaries as study guides.

• Radio frequency 
technology

The Senteo system’s robust radio frequency technology has a range 
of up to 100 ft. (30 m) and doesn’t need a line-of-sight path.

Clicker Features
• Large LCD screen The screen displays three lines of text.
• Descriptive icons LCD screen icons show battery and connection status.
• Ergonomic design The handheld clicker is designed to fit comfortably in young hands, 

and the 21 input buttons are conveniently located and easy to use.
• Extended battery life Each clicker uses two AA batteries, which are long-lasting and easy 

to replace.

Receiver Features
• Convenient connection The receiver connects easily using a USB connection and doesn’t 

need an additional power adaptor.
• Flexible installation The receiver can be either mounted on a wall or placed on a desk.
• Convenient 

maintenance features
LED lights indicate power status and give visual indications of sent 
and received information. 
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Section 1: Installing the Senteo 
Interactive Response System

Environmental Requirements
Before installing or using your Senteo interactive response system, review the following 
environmental requirements and compliance statements.

Temperature

Senteo interactive response system components can operate in the temperature range of 
41°F to 95°F (5°C to 35°C). In addition, the product can withstand storage temperatures from 
-40°F to 120°F (-40°C to 50°C).

Humidity

Senteo interactive response system components can operate in up to 80% relative humidity 
non-condensing.

Water and Fluid Resistance

Senteo interactive response system components are for indoor use only and do not meet any salt-
spray or water ingress requirements. Do not pour or spray any liquids directly onto the Senteo 
interactive response system components. These liquids might get into areas where they could 
damage sensitive electronic components. Refer to page 35 for detailed instructions on cleaning 
your Senteo interactive response system components.

Dust and Scratching

Senteo interactive response system components are for use in office and classroom environments 
and are not for industrial use where heavy dust and pollutants can cause malfunctions or impaired 
operation. They are designed for pollution degree 1 (P1) as per EN61558-1, which is defined as 
“No pollution or only dry non-conductive pollution.”

Electrostatic Discharge (ESD)

Senteo interactive response system components meet the requirements of EN61000-4-2 severity 
level 4 for direct and indirect ESD. No malfunction or damage up to 15kV (both polarities) with a 
330 ohm, 150 pF probe (air discharge). Un-mated connectors meet 8kV for direct (contact) 
discharge.

Conducted and Radiated Emissions

The narrowband radiated electric field from Senteo interactive response system components 
meets the limits for Class B performance as defined in EN55022/CISPR 22.
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Installing Senteo Software

System Requirements

Windows Computers

Pentium® II 450 MHz processor
128 MB of RAM (256 MB recommended)
136 MB of free hard disk space for minimum installation 
(511 MB for full installation with Gallery collections)
Windows 2000 operating system or later
Microsoft Internet Explorer® 6.0 or later
Adobe® Flash® player version 9

Mac Computers

700 MHz processor (1 GHz or faster recommended)
128 MB of RAM (256 MB recommended)
Mac OS X version 10.4.8 (10.4.6 not supported) 
180 MB of free hard disk space for minimum installation 
(511 MB for full installation with Gallery collections)
Adobe® Flash® player version 9

Senteo Software Components
In the following procedures, you will install all of these software components:

• Senteo Manager software
• Driver software for the receiver
• Notebook software, including the Senteo menu

1. Put the Senteo software CD into your computer’s drive. 
The installation wizard appears. 
If it doesn’t start automatically, locate and double-click the 
SenteoSoftwareSetup.exe file.

2. Click Next to start the wizard. 
The Licence Agreement dialog box appears.

3. Select the I accept option, and click Next. 
4. Click Next to install the software to the default folder.
5. Click Install to start the installation.
6. Click Finish to complete the installation.

After a short delay, a balloon message appears in the 
notification area. 

7. Click the balloon message to create a classroom.
A dialog box appears.

8. Type a unique classroom name into the box, and click OK.

To install Senteo software on Windows computers
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1. Put the Senteo software CD into your computer’s drive. 
The Senteo Install CD window appears. 

2. Click the Senteo Icon. 
3. Click Continue. 
4. Click Continue again.
5. Select the destination volume, if there is more than one.
6. Click Install to start the installation.
7. Click Continue to complete the installation.

After a short delay, a message appears asking you to restart the computer. 
8. Click Restart.

You must register your Senteo software within 30 days of installation to keep it active. You can use 
the steps below to activate the software using an Internet connection, or you can activate it 
manually.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Activate Senteo Software.
The Software Evaluation dialog box appears showing how 
many days you have left in the evaluation period.

2. Click the Activate License button.
3. Type your Senteo software’s serial number and e-mail 

address into the boxes, and click Next.
If you haven’t yet purchased Senteo software, click the 
Purchase Senteo Software Licence button, and use one 
of the links to contact SMART Technologies.

4. If you have an Internet connection, select Yes, I am 
connected, and click Next.

5. Click Finish to complete the activation.

To install Senteo software on Mac computers

To activate Senteo software
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Installing and Setting Up Senteo Hardware

Connecting the Receiver to a Computer

The receivers have a USB 2.0 full-speed peripheral interface that runs at speeds of up to 12 Mbps. 
The unit works with USB 2.0- and USB 1.1-compliant USB interfaces.

Recommended Height for Mounting the Receiver

While not requiring an unobstructed line-of-sight transmission path, such as that required by 
infrared devices, you can operate the Senteo system over larger distances if you minimize 
interference, signal reflections and the number and size of objects between the receiver and the 
clickers.

Choose a location for the receiver that is as high as possible, and in plain view of the student’s 
clickers. For permanent installations, you can use a USB extender so that you can mount the 
receiver high on a wall. To minimize interference from other radio-frequency equipment, position 
the receiver away from other wireless products, such as 2.4 GHz routers and cordless telephones. 

1. For temporary installations, place the receiver 
on top of your desk. 
For permanent installations, you can mount the 
receiver on a wall or on the front of a piece of 
furniture using two screws (not provided).
Orient the receiver with the long side or edge 
facing the class as shown.

2. Insert the captive USB receiver cable’s 
connector into an available USB receptacle on 
your computer.
On Windows computers, the Add Hardware 
Wizard appears.
On Mac computers, a balloon message 
appears indicating that the hardware is ready 
to use. The top LED indicator on the receiver 
turns red to indicate that it is receiving power.

IMPORTANT For operating safety and to avoid damage to the receiver, you must connect the 
USB connector of the interactive whiteboard only to a computer that has a USB 
compliant interface and that bears the USB logo. In addition, the USB source 
computer must be compliant with CSA/UL/EN 60950 and bear the CE mark and 
CSA and/or UL mark(s) for CSA/UL 60950.

WARNING
To prevent product damage or personal injury, route the USB cable where it won’t 
be stepped on or tripped over.

To connect the receiver

Temporary 
Desktop  

Installation

Permanent 
Vertical 

Installation
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3. If the Found New Hardware wizard doesn’t start automatically, click Start > Settings > 
Control Panel > Add Hardware.

4. Select the Yes, this time only option and click Next.
5. Click Next to start the hardware installation.
6. Click Finish to complete the first installation cycle.

After a short delay, the Add Hardware Wizard appears again.
7. Repeat steps 4 through 6.

A balloon message appears indicating that the hardware is ready to use. The top LED 
indicator on the receiver turns red to indicate that it is receiving power.

NOTE: If you assigned a classroom name while performing the software installation procedure on 
page 4, you don’t need to perform this procedure. 

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Configure Hardware. 
A Senteo Configuration Wizard appears. 
NOTE: The wizard appears if you haven’t previously 
assigned a classroom name. If you previously assigned a 
classroom name, the Senteo Manager software appears.

2. Click Next.
3. Type a classroom name of up to eight characters into the  

box, and click OK.
A dialog box appears saying that your installation is 
complete.

Extending the USB Cable

If the provided 6' (1.8 m) USB cable attached to the receiver isn’t long enough, you can use active 
USB extender cables, USB extenders or hubs.

The illustration to the right shows the SMART active 
USB extension cable (Part No. USB-XT). In some 
cases, you may be able to use up to four cables to 
extend the length to about 80' (25 m), which is the limit 
of the USB specification. Note that passive USB 
extension cables are not supported.

NOTE: Some computers use internal active hubs to 
provide more USB receptacles. The computer’s 
operating system may see these internal hubs as 
external devices, limiting the number of USB 
extenders that you can use.

Alternately, USB extenders that use Cat 5 cabling can extend the range to approximately 325' 
(100 m), at a much higher cost. The more economical SMART USB extender pair (Part No. 
CAT5-XT) shown on the next page can extend the USB connection up to 120' (36.6 m) using an 
RJ45 Cat 5 cable.

To name the classroom
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These units require that you use the provided 6' 5" 
(2 m) cables or use cables and connectors that meet 
the same specifications. Impedance mismatches and 
poor connections can cause signal degradation and 
performance problems.

USB hubs should also work with receivers. If you also 
use streaming audio through a shared USB hub, the 
receiver’s performance might become intermittent or 
otherwise unacceptable. 

USB extenders and hubs must be USB 1.1 or USB 2.0 compliant to work correctly. They must also 
provide at least 100 mA to the receiver.

Renaming the Classroom
When you installed Senteo software, you assigned a classroom name to the receiver’s network 
(see page 4 and page 7). If you move the Senteo hardware to another location, you can use the 
following steps to change the classroom name. 

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.

2. Click the Students tab (Windows operating systems) or 
button (Mac operating systems) if it isn’t already selected.
The Students page appears.
NOTE: You can’t change the classroom name if the receiver 
is on. To turn the receiver off, click Off (Power Save).

3. Click Edit > Classroom Information, or click the blue 
underlined text beside Classroom Name.
The Classroom Name dialog box opens.

4. Type a new name into the text box, with a maximum of eight 
characters, and click OK.

To change the classroom name
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Section 2: Managing Senteo System 
Hardware

Senteo Manager is your primary tool for checking the receiver and clicker status, evaluating 
student performance, selecting the mode of operation, managing class lists, starting and stopping 
sessions, and viewing historical information about students and clickers.

NOTE: You can safely close Senteo Manager while clickers are connected and question sets are 
running. You can restart the manager at any time from the Windows notification area or Mac menu 
bar, or by clicking Senteo > Senteo Manager in Notebook software.

Checking the Receiver
If you have installed the receiver using the procedure on page 6, you are ready to start a class 
session. You can check the communication status at any time using the following procedure., 

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Configure Hardware. 

2. Click the Receivers tab (Windows operating systems) or 
button (Mac operating systems) if it isn’t already selected.
– If a message that reads "The Senteo Receiver is 

working properly" appears, the Senteo receiver is 
connected and in one of the "On" modes.

– If a message that reads "The Senteo Receiver is in Off 
(Power Save) mode." appears, the receiver is 
connected and working properly, and is ready to be 
switched to an "On" mode.

– If a message that reads "No receivers are detected" 
appears, check the receiver’s USB connection or repeat 
the procedure on page 6.

Selecting Receiver Channels
Senteo software tells the receiver to scan all sixteen available channels and select one 
automatically based on the signal strength and quality. The software selects the channel when you 
switch the receiver to an "On" mode. The selected channel number appears at the bottom of the 
Receivers page. When the receiver is off, the channel is unassigned.

If you suspect that there is another device interfering with the channel Senteo software has 
selected, you can also use Senteo Manager to check the channel quality and manually select a 
channel using the following procedure.

To check the receiver status
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1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select 
Configure Hardware. 

2. Click the Receivers tab (Windows operating systems) or button (Mac operating systems) if it 
isn’t already selected.

3. Click the options arrow beside the Status button and select the Off (Power Save) option. If 
the receiver is in this mode already, go to step 4.
A message appears on the clickers indicating that the class is over and the clickers are turning 
off. 
NOTE: The receiver must be in the Off (Power Save) mode before you proceed.

4. Click the Channel Options text in the lower-right of the page.
The Receiver Channel Options dialog box opens listing the signal quality and Network ID of 
channels 11 through 26. To manually refresh the list, click Refresh.

5. To manually select a channel, click the desired channel, and then click Apply.
The Receivers page displays the selected channel.
If you want to return Senteo Manager software to automatic selection later, click Auto 
Channel Selection in the Receiver Channel Options dialog box.

6. Click OK to close the dialog box.

Selecting the Operating Mode
Before you start a class session, you must decide in which of two modes you want the system to 
operate; On (Anonymous mode) and On (Sign In Required) mode. The following table summarizes 
the characteristics of each mode. 

To check channel quality or manually select a receiver channel

Anonymous Mode Sign In Required Mode
You can operate the system without a class 
list.

You must operate the system with a class list that 
identifies each student by name and a unique ID 
number.

Students can connect their clickers without 
identifying themselves.

Students can connect their clickers but must log on 
with their assigned ID number.

Under the teacher’s control, students may 
see their own scores but can’t see any 
other students’ scores.

Under the teacher’s control, students may see their 
own scores but can’t see any other students’ 
scores.

Teachers can see how many clickers are 
connected.

Teachers can identify individual students as they 
connect and log on with their clickers.

Teachers can see, export and print the total 
class score. 

Teachers can see, export and print the total class 
score. 

Teachers can see, export and print total 
scores for each question.

Teachers can see, export and print total scores for 
each question.

Teachers cannot identify students’ names 
or their individual scores.

Teachers can see, export and print each student’s 
score for each question and their total score.
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Starting in On (Anonymous) Mode
You don’t require a class list to operate the Senteo system in On (Anonymous) mode.

NOTE: If you start a question set with the Remember names option selected (see page 27), a 
dialog box appears asking you to disable the option or return to Senteo Manager software to 
restart the session in On (Sign In Required) mode.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears. The Students page 
displays the most recent class list, or an empty class list.
If the Students page doesn’t appear automatically, click the 
Students tab (Windows operating systems) or button (Mac 
operating systems).

2. Click the options arrow beside Status and select the On 
(Anonymous) option.
The receiver’s power LED flashes and then turns solid 
green, and the receiver’s transmit LED flashes green. After 
a short delay, a “Senteo is ready to use” message appears, 
indicating that the clickers can be turned on.

Starting in On (Sign In Required) Mode
Before you can start the Senteo system and connect the clickers in this mode, you must open a 
class list. If you don’t have a class list, go to page 12 for procedures for creating or importing class 
lists.

1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select View 
Class.
The Senteo Manager window appears. The Students page displays the most recent class list, 
or an empty class list.
If the Students page doesn’t appear automatically, click the Students tab (Windows operating 
systems) or button (Mac operating systems). 

2. Select File > Open Class List or click .
3. Browse to and select the .classlist file that you want to use, and then click Open.

A list of students and their status appears.
4. Click the options arrow beside the Status button and select the On (Sign In Required) option.

The receiver’s power LED flashes, and then turns solid green, and the receiver’s transmit LED 
flashes green. After a short delay, a “Senteo is ready to use” message appears, indicating that 
the clickers can be turned on.

To start in On (Anonymous) mode

To start in On (Sign In Required) mode
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Managing Class Lists

You can use Senteo Manager software to create, import or modify class lists. 

NOTE: You can’t create, import or modify class lists while a question set is in progress.

Creating Class Lists

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears. The Students page 
displays the most recent class list, or an empty class list.
If the Students page doesn’t appear automatically, click 
Students.

2. Select File > New Class List or click .

3. Select Edit > Add Student or click .
The Add Student dialog box appears.

4. Type a student’s name into the Name boxes.
The last name is optional.

5. Type a unique number of up to fifteen digits into the ID box.
6. Type the student’s e-mail address into the E-mail Address box (optional), and click OK. 
7. Repeat steps 3 through 6 for each student.
8. Select File > Save Class List As and type a file name for your class list.
9. Select a folder for the class list file, and click Save.

Importing Class Lists from Microsoft Excel™ (Windows 
Operating Systems, Only)
If you use Microsoft Excel to maintain student rosters, you can import an .xls file into Senteo 
Manager software to create a class list. 

NOTE: You may find it easier to copy the list of names into a new Excel spreadsheet.

1. Open the spreadsheet listing your student names in 
Microsoft Excel.

2. Insert a blank row at the top of the spreadsheet, if it doesn’t 
already have one. 

3. In the first cell (A1) type ID Number.
4. In the first cell of the second column (B1) type First Name.
5. In the first cell of the third column (C1) type Last Name.
6. Arrange the student’s first and last names into columns 1 and 2, directly below the headings.
7. Type each student’s unique ID number into the first column, and then save the spreadsheet.

To create a class list

To create a class list in a Microsoft Excel spreadsheet
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1. Click the Senteo icon in the notification area and select View 
Class.
The Senteo Manager window appears displaying the student 
list.

2. Select File > Import Class List From > Excel or click .
The Open dialog box appears.

3. Browse to the Excel spreadsheet file, select it and click OK.
After a short delay, the list of names from your Excel 
spreadsheet appears in the Students page.

4. Select File > Save Class List As.
5. Browse to a destination folder, type a file name for the class 

list, and click OK.

Modifying Class Lists

You can modify student information in Off (Power Save) mode and in On (Sign In Required) mode. 
You can’t modify student information while a question set is running.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears. The Students page 
displays the most recent class list, or an empty class list.
If the Students page doesn’t appear automatically, click 
Students.

2. Right-click the student name and select Student 
information, double-click the student name, or select the 

student name and click .
The Student Information dialog box appears.

3. Make the desired changes and click OK.
4. Repeat steps 2 and 3 for other names, as required.

5. Select File > Save Class List or click .

To import a class list from Microsoft Excel

To modify student information
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NOTE: You can add students in Off (Power Save) mode and in On (Sign In Required) mode.

1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select View 
Class.
The Senteo Manager window appears. The Students page displays the most recent class list, 
or an empty class list.
If the Students page doesn’t appear automatically, click Students.

2. Select File > Open Class List or click the .

3. Select Edit > Add Student or click  button.
The Add Student dialog box appears.

4. Type a student’s name into the Name text boxes.
The last name is optional.

5. Type a unique number of up to fifteen digits into the ID box.
6. Type the student’s e-mail address into the text box (optional), and click OK. 
7. Repeat steps 3 through 6 for each new student.

8. Select File > Save Class List or click .

You can remove students from a class list in Off (Power Save) mode only. You can’t remove 
students from a class list while in On (Sign In Required) mode or when a question set is running.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears. The Students page 
displays the most recent class list, or an empty class list.
If the Students page doesn’t appear automatically, click 
Students.

2. Select File > Open Class List or click .
3. Select the student you want to remove and click 

Edit > Remove Student or click .
A dialog box appears asking you to confirm the deletion.

4. Click OK.
5. Repeat steps 3 and 4 for each student.

6. Select File > Save Class List or click .

To add a student to a class list

To remove a student from a class list
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Connecting and Disconnecting the Clickers

Connecting Clickers in On (Anonymous) Mode
NOTE: In this mode, each student must know the classroom name.

When the “Senteo is ready to use” balloon message appears, tell your students to follow these 
steps:

1. Press the Power button on the clicker for one second.
A message appears asking if you want to join the last class the clicker was connected to, or 
find a different class. 

2. Press the Down button to select Find a class, and press Enter.
The clicker scans for classes, and then displays a list of classes within range.

3. Press the Up and Down buttons to select the correct class, and then press Enter.
A welcome message appears. When all the students are connected, you are ready to start 
asking questions.

Connecting Clickers in On (Sign In Required) Mode
NOTE: In this mode, students must know the classroom name and the unique ID number you 
assigned to them when you created the class list. See steps 4 and 5 on page 12.

When the “Senteo is ready to use” balloon message appears, tell your students to follow these 
steps:

1. Press the Power button on the clicker for one second.
A message appears asking if you want to join the last class the clicker was connected to, or 
find a different class. 

2. Press the Down button to select Find a class, and press Enter.
The clicker scans for classes, and then displays a list of classes within range.

3. Press the Up and Down buttons to select the correct class, and then press Enter.
A connecting message appears, followed by a message asking for an ID number.

4. Press the number buttons to enter your ID number, and press Enter.
A message appears asking you to confirm your name.

5. Press the Enter button to connect. 
A welcome message appears.

When all the students are connected, you are ready to start asking questions. Refer to page 18 for  
information about using SMART Notebook software to ask questions and create question sets.

NOTES

• When a student uses an ID that isn’t in the current class list, a message appears on the clicker 
that reads “Unknown ID, Sign in?”. Pressing Y logs the student on in Anonymous mode. The 
anonymous student’s clicker appears in Senteo Manager software’s Clickers page and in the 
Students page. You can then add the student to the class list. See page 13 for more 
information about editing class lists.

• If two students log on with the same ID, the first student is logged off and “You signed in on 
another clicker” appears on the clicker’s display.
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Disconnecting the Clickers
You can disconnect and turn off all clickers simultaneously. However, you can’t use Senteo 
Manager software to disconnect the clickers while a question set is running. 

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears displaying the class 
list.

2. Stop your question set, if it is running.
If a question set is running, a “Questions in Progress” 
message appears beside the classroom name.

3. Click the Status button and select the Off (Power Save) 
option. 
A message appears on the clickers indicating that the class 
is over, and the clickers are turning off. The power, transmit 
and receive LEDs on the receiver turn off.

Students can disconnect their clickers simply by pressing the Power button for one to two 
seconds. If they turn off their clickers while a question set is running, students can turn the clickers 
back on, log on and rejoin a question set in progress without losing the answers they had 
previously entered.

If students connect to the wrong class, ask them to log off by pressing the Menu button, selecting 
Sign out, and then pressing the Enter button. They can then connect and log on to the correct 
class without turning off their clickers.

To disconnect all clickers using Senteo Manager software

To disconnect individual students’ clickers
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Section 3: Using the Senteo System with 
Notebook and PowerPoint 
Software

About SMART Notebook Software
Use Notebook software to save notes written on a SMART Board interactive product or at your 
computer as a series of pages. You can also use Notebook software to create a presentation that’s 
full of colorful clip art, Macromedia Flash objects, graphics and text from a variety of sources. You 
can then present that Notebook file, keeping your audience’s attention as you move and interact 
with these objects. When your audience provides comments and suggestions, write their input on 
a Notebook page using the pen tray tools or the pen buttons in Notebook software.

Because Notebook software works on many platforms, you can share files created on a Windows 
computer with people who use a Mac computer. You can share your Notebook file as a cross-
platform HTML, PDF or .notebook file, or as a series of image files.

Notebook Software with Senteo Software
SMART’s addition of Senteo software to Notebook software means that you can create question 
sets, import questions from Microsoft Word or XML files and start and stop question sessions 
directly from Notebook software. You can export the class’ and individual student’s results to a 
Microsoft Excel file or an HTML page. Using Senteo software’s printing feature, you can also 
create handout materials, copies of the questions and marked results pages for each student and 
for the class.

This section introduces the Senteo software features of Notebook software. For more information 
about using other features of Notebook software, refer to Notebook software’s online Help or the 
SMART Web site.
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Using Notebook Software to Ask Questions and Create 
Question Sets

Notebook software features five types of questions that you can ask either individually or grouped 
as question sets. You can also add notes to questions that appear when you print the question 
results.

Question Types

Asking Questions with Notebook Software
You can use Notebook software to create individual questions that you can ask students, and then 
collect their answers.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Ask Questions.

2. Select Senteo > Insert Question or click .
The Insert Question wizard appears.

Question Type Description
Yes or no Students must use the Y or N buttons to answer a question. You can 

also choose the Opinion option allowing any answer.
Multiple choice Students must use a single button, A through J, to answer the 

question. Select from 2 to 10 answers for a question. You can also 
choose the Opinion option allowing any answer.

Number, fraction or 
decimal

Ask a question with a numeric answer using whole numbers, 
fractions or decimals.

True or false Students must use the T or F buttons to answer a question. You can 
also choose the Opinion option allowing any answer.

Multiple answer Students use the A through J buttons to select the correct 
combination of answers to the question. Select from 2 to 10 answers 
for the question. You can also choose the Opinion option allowing 
any combination of answers.

To add a question using the Insert Question wizard
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3. Select the thumbnail for the desired question type, and click Next.
4. Type the question into the text box, and click Next.
5. For Yes or No, and True or False questions, select the correct answer, or the Opinion option.

For Number, fraction questions, type the correct answer.
For Multiple choice or Multiple answer questions, select the number of answers, type the 
answers into the text boxes, click Next and then select the correct answers or the Opinion 
option.

6. Click Finish.
Your question appears in the Notebook page with this dialog box in the top-right corner.

You can use Notebook software’s tools to add images or Flash objects from the Notebook 
Gallery, if desired.

7. If you don’t want to track each student’s answers, or if the clickers are in Anonymous mode, 
clear the Remember names check box.
NOTE: If you create another question on a new Notebook page, a message appears asking if 
you want to add a title page to the questions, which will group them together.

NOTE: Make sure that all student’s clickers are connected before asking questions (see page 15 
for more information). 

1. Click the Start button on the Notebook page.
A message appears on the clickers asking the students to respond with their answers.

2. When all students have answered, click Stop.
The class results appear on the page.
NOTE: Notebook software stores the results in your document. Remember to save your 
document after collecting responses.

3. To ask the same question again, right-click on the Notebook page, and select Clear.
If there are other questions in your document, a message appears asking if you want to clear 
them all.

4. If you want to save the question as a .notebook file, click File > Save (or Save As) or click .
A Save As dialog box appears. Browse to a destination folder, type a file name for the 
.notebook file and click Save.

To collect question responses



20 Using Notebook Software to Ask Questions and Create Question Sets

Creating Question Sets with Notebook Software
When you ask individual questions, you can view and collect results data for each question. By 
creating question sets, you can collect results for a set of questions at the same time. You can print 
and hand out the question set so that students can answer the questions at their own pace.

NOTE: You can install Senteo software on a computer that isn’t connected to a receiver and create 
question sets that you can later copy to and run on the computer system in your classroom.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Ask Questions.
Notebook software appears with a blank page.

2. Select Senteo > Insert Title Page. 
This Notebook page appears.

3. Select the top row of text and type a title for your question set.

4. Select Senteo > Insert Question or click .
The Insert Question wizard appears.

5. Select the thumbnail image for the desired question type, and click Next.
6. Type the question into the text box, and click Next.
7. For Yes or No, and True or False questions, select the correct answer, or the Opinion option.

For Number, fraction questions, type the correct answer.
For Multiple choice or Multiple answer questions, select the number of answers, type the 
answers into the text boxes, click Next and then select the correct answer or the Opinion 
option.

To create a question set
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You can use Notebook software tools to add images or Flash objects from the Notebook 
Gallery, if desired.
Your question appears in an individual Notebook page with this object in the top-right corner.

8. Repeat steps 4 through 7 until you have added all your questions.
9. Select the title page in the Page Sorter.

The title page changes to show options and a Start button.

10. Select File > Save (or Save As) or click .
The Save As dialog box appears.

11. Browse to a destination folder, type a file name for the .notebook file, and click Save.
You can run the question set on this computer, or copy the .notebook file to any computer that 
has Senteo software installed. For more information. see page 17.
NOTE: You can’t run a question set .notebook file on a computer with standard Notebook 
software installed. You must have Notebook software that includes Senteo software.
To print the questions as a student handout, see page 25.
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Importing Questions from Microsoft Word
When importing questions from a Microsoft Word document, Senteo software’s conversion 
software uses a variety of techniques to identify which paragraphs are questions, which are 
possible answers and what type of question to create. Its most basic technique is to look at the 
numbering of the paragraphs. The software also looks for key words when parsing the paragraphs. 
The software then converts the paragraphs into question set Notebook pages.

The text below shows examples of five questions formatted so that Senteo software can easily 
convert them to question pages. Notice that the last question isn’t numbered, but Senteo software 
can successfully create a question by recognizing a key word.

NOTE: Senteo software can’t provide the correct answers to the imported questions.

Example Word Document Question Formats

1. According to the U.S. Census Bureau, the majority of poor children live in:
a. urban areas 
b. suburban areas 
c. rural areas

2. Can you fill a 10 L aquarium with five 2 L pitchers of water?
Yes
No

3. True or false: Half of all even whole numbers are divisible by 4.
True
False

4. Let x = 3. Compute y from the equation below.
y = 20 - 4x 
Answer: ____________________________

Which Native American group lived in the highlighted area on the map?
a. Kwakitul
b. Sioux
c. Iroquois
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NOTE: Ensure that the questions in your Microsoft Word document are formatted like the example 
on the previous page before you begin this procedure.

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Ask Questions.
A blank Notebook software page opens.

2. Select Senteo > Import Question From > Microsoft 
Word.

3. Locate and select the Word document, and click Open.
A progress bar appears, followed by the title page for the 
new question set.

4. In the Page Sorter view, select the first question page.
5. Edit and customize the page, as required.

Check the question carefully to verify that the conversion 
process was accurate.

6. Repeat steps 4 and 5 for all questions in the set.

1. In the Page Sorter view, select the first question page.
2. Select Senteo > Set Answer.

The Set Answer dialog box appears.
3. Type or select the correct answer(s) from the options, and click OK.
4. Repeat steps 1 through 3 for all questions.

5. Select File > Save (or Save As) or click .
The Save As dialog box appears.

6. Browse to a destination folder, type a file name for the .notebook file, and click Save.
You can run the question set on this computer, or copy the question set .notebook file to any 
computer that has Senteo software installed.
NOTE: You can’t run question set .notebook files on a computer with standard Notebook 
software installed. You must have Notebook software that includes Senteo software.

To import questions from a Microsoft Word document

To set the answers for imported questions
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Importing Questions from XML or SQZ Files
Senteo software includes an import feature to convert questions from XML files in ExamView® 
format or SMART SynchronEyes® SQZ files into question sets. Senteo software uses the tags in 
the XML and SQZ files to extract questions, answers and correct responses, and then converts the 
information into question set pages.

NOTE: You must have an ExamView formatted XML file or a SynchronEyes SQZ file before you 
can perform this procedure.

1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select Ask 
Questions.
A blank Notebook software page opens.

2. Select Senteo > Import Question From > XML.
3. Locate and select the XML or SQZ file, and click Open.

A progress bar appears, followed by a the title page for the new question set.
4. In the Page Sorter view, select the first question page.
5. Edit and customize the page, as required.

Check the question carefully, including the correct answer, to verify that the conversion 
process was successful.

6. Repeat steps 4 and 5 for all questions in the set.

7. Select File > Save (or Save As) or click .
The Save As dialog box appears.

8. Browse to a destination folder, type a file name for the .notebook file, and click Save.
NOTE: You can’t run question set .notebook files on a computer with standard Notebook 
software installed. You must have Notebook software that includes Senteo software.

To import questions from an XML or SQZ file
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Printing from Notebook Software’s Senteo Menu
You can print a variety of information from the Notebook software Senteo menu. You can create 
and include header, footer and date information, and select a page range to print. 

Print Option Description
Thumbnails Prints from one to six full-color reduced images of each question set 

page on one page. You can choose to include page numbers, image 
borders and question page titles.

Handouts Prints from one to three full-color reduced images of each question 
set page together with ruled lines for note taking on one page. You 
can choose to include page numbers, image borders and question 
page titles.

Full page Prints one full-color image of each question set page on a page. You 
can choose to include page numbers.

Questions Prints several question set questions on a page. If the question page 
doesn’t have any objects or images, the questions appear on the 
page in text-only format. If there are objects on the question page, a 
full-color thumbnail of the question appears. You can choose to 
include page numbers.

In the Print Preview view, you can click the question to toggle from 
thumbnail to text-only format.

Results NOTE: This option is only available after stopping a question or 
question set.

Prints several question set questions on a page. If the question page 
doesn’t have any objects or images, the text only appears on the 
page. If there are objects on the question page, a full-color 
thumbnail of the question appears. 

The correct answer and the student’s response appears beside 
each question, and the total score appears at the top of the first 
page. You can choose to include page numbers.

You can print a results summary for all students in the class list, or 
you can print the results for select students.
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Using the Senteo System in the Classroom

Before Class Begins

When you use Notebook software to ask questions, Senteo software uses the options you set in 
Senteo Manager software to control how students use their clickers. We recommend that you 
follow the steps below before each class.

1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select View 
Class.
The Senteo Manager window appears. The Students page displays the most recent class list, 
or an empty class list.

2. Open a class list, if required. 
Refer to the following tables and information on page 10 to decide if you need to open a class 
list. 

3. Click the options arrow beside the Status button and select the desired option. 

Choosing a Startup Sequence
You can turn on the receiver before or after you start your questions. Use the following tables to 
help decide your preferred sequence.

NOTE: If the Senteo system is in Off (Power Save) mode when you plug in a receiver, Senteo 
Manager software turns the receiver on automatically.

Safety Tips for Teachers 
When using the Senteo system with a SMART Board interactive whiteboard and a 
projector:

• Tell students not to look directly at the light beam from the projector. Instead, 
encourage them to keep their back to the projector when working at the 
interactive whiteboard. Before they turn to face the class, they should take a 
big step (or even two) sideways.

• Make sure you don’t look directly into the light beam from the projector. Keep 
your back to the class when you write over a projected image. Step to the 
side of the interactive whiteboard before you turn and face the class.

• Tell your students not to touch the projector, as it can become extremely hot 
during normal operation.

• Don’t use a chair to increase a student’s reach. If your students can’t reach 
the top of the interactive whiteboard, lower it. You may need to remount a 
wall-mounted unit to a lower position. If your interactive whiteboard is 
mounted on a floor stand, lower it with the help of another adult.

• Tell students not to run in the vicinity of the floor stand, as they may trip over 
the floor stand’s feet.

To start Senteo Manager software
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Turning On the Receiver Before Starting Questions

The following table shows what to expect if you turn on the receiver (using Senteo Manger 
software) before starting a question set.

Turning On the Receiver After Starting a Question Set

When you click the Start button in a Notebook page and Senteo Manager software is in Off (Power 
save) mode, Notebook software signals Senteo Manager software to turn on the receiver. The 
following table shows what to expect if you start a question set before turning on the receiver. 

Option Selected Description
No class list open in Senteo Manager 
software.

Remember names option selected in 
question set.

The Senteo system starts in On (Anonymous) mode. 

A message appears asking you to disable the 
Remember names option, or go to Senteo Manager 
software to load a class list and turn on the receiver in 
On (Sign In Required) mode.

Class list open in Senteo Manager 
software.

Remember names option selected in 
question set.

The Senteo system starts in On (Sign In Required) 
mode.

Notebook software records individual student results.

No class list open in Senteo Manager 
software.

Remember names option deselected in 
question set.

The Senteo system starts in On (Anonymous) mode.

Notebook software doesn’t record individual student 
results.

Class list open in Senteo Manager 
software.

Remember names option deselected in 
question set.

The Senteo system starts in On (Sign In Required) 
mode.

Notebook software doesn’t record individual student 
results.

Options Selected Description
Remember names option selected in 
question set.

No class list open in Senteo Manager 
software.

A message appears asking you to disable the 
Remember names option, or go to Senteo Manager 
software to load a class list and turn on the receiver in 
On (Sign In Required) mode.

Remember names option selected in 
question set.

Class list open in Senteo Manager 
software.

Notebook software signals Senteo Manager software to 
turn on the receiver in On (Sign In Required) mode, 
using its current class list.

Remember names option deselected in 
question set.

Class list not open in Senteo Manager 
software.

Notebook software signals Senteo Manager software to 
turn on the receiver in On (Anonymous) mode.

Remember names option deselected in 
question set.

Class list open in Senteo Manager 
software.

Notebook software signals Senteo Manager software to 
turn on the receiver in On (Sign In Required) mode, 
using its current class list. Students must sign in, but 
Notebook software doesn’t collect student results.
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Using the Clickers
Before asking questions, review the clicker’s operation with the students.

Clicker Buttons and Features

Clicker Button Description
Power Press for one second to turn the clicker on.

Press for one to two seconds to turn the clicker off.
Selection Scroll up and down option lists.
True/False Answer true or false questions.
Alphanumeric Answer multiple choice and numeric questions.
+ / – Make a numeric answer positive or negative.
Enter Make or confirm a selection.
Ask Question Alert teacher or to ask a question. See next page for details.
Menu Open clicker menu. See the table on the next page for details.
Delete Delete alphanumeric characters entered.
Fraction/Decimal Create fractional or decimal numeric answers.

LCD Display

+ / – Button

True/False 
Buttons

Alphanumeric 
Keys

Power Button

Menu Button

Delete Button

Fraction / 
Decimal 
Button

Selection 
Buttons

Ask Question 
Button

Enter Button
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Receiving Student Questions

A student can request the teacher’s attention at 
any time by pressing the Ask Question button 
on their clicker. Senteo Manager software 
displays the student’s name in the Questions 
list above the Clickers list on the Clickers page. 
An anonymous student’s clicker displays "Not 
logged on" in the Questions list.

The total number of students with questions 
appears in the Legend area of the Senteo 
Manager window.

To clear the question from Senteo Manager 
software, select the clicker in the Questions list, 
and then click Manage > Clear Question or right-click the student name and select Clear 
Question.

Using the Menu Button

Students can press the Menu button at any time to log off the session or to modify the clicker’s 
settings. The following options are available in the menu: 

Option Description
Sign Out Press to log off a class without turning off the clicker.
Language Press to select the language displayed on the clicker’s LCD panel.
Contrast Press to lighten or darken the clicker’s LCD panel. Use the Up and Down 

arrows to increase or decrease the contrast.
Device info Press to display the clicker’s MAC address and firmware version.
Advanced You must have a valid security code to open this menu. Your customer 

support representative may provide the code to help troubleshoot clicker 
problems.
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Starting a Question Set
Before starting a question set, check that the receiver is connected and ready. Refer to page 9 for 
more information.

1. Click the Senteo icon in the Windows notification area or Mac menu bar, and select Ask 
Questions.
A blank Notebook software page appears.

2. Select File > Open.
3. Select the Notebook file with your questions, and click Open.

A question set title page similar to this example appears.

4. Choose the Privacy and Show grades on the clickers options. 
The following table details each option. 

5. If the students haven’t connected their clickers, have them do so now. See page page 15 for 
instructions.

6. Click the Start button.
The title page changes to a progress page showing a graph of the percentage of total student 
answers for each question. 

To open and start a question set

Option Description
Remember names When Senteo Manager software starts the receiver in On 

(Sign In Required) mode, Notebook software collects results 
for each student.

If you deselect this option, Notebook software doesn’t 
collect student results.

Show grades on clickers after 
all questions are answered

The clicker shows how the students answered and their 
grade after they finish answering all questions.

Show grades on clickers after 
each question is answered

The clicker shows how the students answered after each 
question, and shows their grade after they finish answering 
all questions.

Show grades after you stop 
collecting responses

The clicker shows how the students answered after you 
click the Stop button. The grade isn’t displayed.

Don’t show grades on clickers The clickers don’t show results or grades.
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7. If you are projecting the questions on a wall screen, you can control the students’ progress by 
selecting each question page in turn. If you provided printed student handouts (see page 25), 
they can control their own pace. 

8. Click the Stop button to end the session.
NOTE: Notebook software stores the results in your document. Remember to save your 
document after collecting responses.

9. Select File > Save (or Save As) or click .

Using Instant Questions
Use the Instant Question feature to introduce the Senteo system to your students. When you use 
Instant Questions, you are unable to type a question, and you can’t assign a correct answer. You 
can ask questions verbally, by writing on a whiteboard or by typing the question and adding objects 
directly into the Notebook page. 

NOTE: Make sure that all student’s clickers are connected before asking instant questions (see 
page 15 for more information).

1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select Ask Questions.
A blank Notebook software page appears.

2. Click the option arrow to the right of  (Windows 
operating systems) or click and hold the button (Mac 
operating systems).
This option list appears.

3. Select the desired Instant question button.
A Notebook page appears showing the possible answers to 
the question and the following dialog box in the top-right 
corner. The question starts automatically, and appears on the clickers.

4. When all students have answered, click Stop.
A dialog box appears showing the class results.

5. To save the results, click File > Save (or Save As) or click .
To ask the same type of question again, click Clear.
To add another question without clearing the results of the previous question, don’t click Clear 
and repeat steps 2 through 4.

To ask individual questions using the Instant Question feature
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Viewing, Printing and Exporting Results
If you save your Notebook file after asking questions, or after running a question set, you can 
reopen the file at any time to view the results. You can print a variety of information, including 
question results, using Notebook software’s Senteo Print menu, as shown on page 25.

You can also export the results to a Microsoft Excel spreadsheet, or to an HTML page for viewing 
on a Web browser.

NOTE: You can only print or export results after stopping the question or question set. Clearing the 
results after stopping the question permanently deletes the information, so you can’t print or export 
the results. After saving and closing the .notebook file, you can reopen the file and print or export 
the results.

1. Stop the question or question set, if it is still running.
Don’t clear the results.

2. Select Senteo > Export results to > Microsoft Excel.
OR
Select Senteo > Export results to > Web Page (HTML).
The Save As dialog box appears.

3. Select a destination folder, type a file name and click Save.
Either Microsoft Excel or your default Web browser opens, showing the exported file.

To export results to a file
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Using the Senteo System with Microsoft PowerPoint

Senteo Software Integrated with PowerPoint
If you install Senteo software onto a computer that has Microsoft PowerPoint presentation 
software installed, a Senteo Question option appears in the PowerPoint Insert menu. You can use 
this option to create and then run questions from within PowerPoint. You can also add Senteo 
software question tools to existing PowerPoint presentations, saving you time if you already have 
your questions in a presentation. 

The following procedures show how to use Senteo software with PowerPoint to create and ask 
questions.

NOTE: You don’t require SMART Notebook software to use Senteo software with PowerPoint.

1. Start PowerPoint software and open a new PowerPoint presentation.
2. Select Insert > New Slide and select a suitable page layout for your question.
3. Select Insert > Senteo Question. 

A  Senteo Question object appears in the slide’s bottom-right corner.
4. Right-click the question object and select Senteo Question Object > Properties.

The Senteo Question Properties dialog box appears.
5. Select the question type. The five options are:

– Multiple choice
– Yes/no
– Number/fraction/decimal
– True/false
– Multiple answer

6. Select the other options and type the answer in the Correct 
answer box as required for the question type selected.
For multiple answer questions, put all answers in a line in the Correct answer text box.

7. Select Remember names or Anonymous mode, and click OK.
8. Add text and objects to the slide, as required.
9. Repeat steps 2 through 8 for all questions.
10. Save the presentation and close PowerPoint.

To create questions in PowerPoint
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1. Click the Senteo icon in the Windows notification area or 
Mac menu bar, and select View Class.
The Senteo Manager window appears. The Students page 
displays the most recent class list, or an empty class list.

2. If you selected the Remember names option, open a class 
list. 
Refer to page 11 for more information.

3. Start PowerPoint and click File > Open, select your 
presentation and click Open.

4. Select Slide Show > View Show or press F5 to start the 
PowerPoint presentation.
PowerPoint software signals Senteo Manager software to 
turn on the receiver, if it isn’t already on.

5. If the students aren’t yet connected, tell them to turn on their 
clickers and log on.

6. Click the Start button on the blue PowerPoint object.

The question’s answer options appear on the clickers and responses are counted in the blue 
box as students submit answers.

7. Click Stop.
The results graph appears on the blue PowerPoint object.

8. Click Clear.
PowerPoint inserts a new slide displaying the question results.

9. Press Page Down, to view the results slide.
10. Press Page Down, to advance to the next question.
11. Repeat steps 6 through 10 until you’ve asked all the questions.
12. Press ESC to stop the presentation, and then click File > Save to save the presentation with 

the results slides.

To run PowerPoint questions
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Section 4: Maintaining the Senteo 
Interactive Response System

Preventing Component Damage
• Don’t use sharp or pointed objects, such as ballpoint pens or pointers, to press the clicker 

buttons.
• Never use abrasive erasers or harsh chemicals when cleaning.
• Avoid setting up and using your system in an area with excessive levels of dust, humidity or 

smoke.

Cleaning the Receiver and Clickers

With proper care, your Senteo hardware will provide years of trouble-free service. Follow these 
tips to keep them clean:

• Remove dust with a damp cloth before using a cleaner.
• Clean the unit’s surface with a household glass cleaner, such as Windex®, daily, weekly or as 

required.
• Do not spray cleaner directly onto the clicker. Instead, spray a light amount of cleaner on a 

cloth and then wipe gently.

Changing Clicker Batteries
Under normal operation, the clicker batteries can operate for up to 200 days. When replacing 
them, use fresh batteries of the same type and quality, and change both at the same time.

1. Using the provided Phillips® screwdriver, remove the screw from 
the back of the clicker, and then remove the cover.

2. Remove the exhausted batteries, and dispose of them according 
to local regulations.

3. Insert new AA batteries as shown. 
The clicker automatically turns on when you insert the batteries.

4. Replace the cover and screw.
5. Verify that the start-up menu appears.
6. Press the Power button for one to two seconds to turn the clicker 

off.

CAUTION • Do not install batteries with the polarity (+/–) reversed.

• Do not attempt to recharge the batteries.
• Do not dispose of batteries in a fire or incinerator.

• Dispose of batteries according to the laws and regulations of your region. If you 
don’t know the applicable rules for your region, consult the battery manufacturer.

To change the clicker batteries
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The Receiver Indicators
The receivers have the following indicators:

• the Ready light
• the Transmit light
• the Receive light

The Ready light LED is in the upper-right corner of the 
receiver’s enclosure. The Ready light indicates the 
operational states of the receiver module. You can see the 
Transmit and Receive lights in the lower-right part of the 
receiver’s enclosure. The lights flash green, indicating 
transmit and receive activity between the receiver and the 
clickers.

NOTE: The following table shows the Ready light’s normal states. If the light’s behavior doesn’t 
match a state listed here, refer to the Troubleshooting the Receiver section below.

Troubleshooting the Receiver

Resetting the Receiver

If your Senteo system behaves erratically (possibly because of a static discharge or power fade) 
you may be able to restore normal operation simply by resetting the receiver.

Reset the receiver completely by disconnecting and then reconnecting the USB cable.

Ready Light State Meaning

Off The receiver is disconnected from the computer, or Senteo Manager 
software has placed the receiver into Off (Power Save) mode.

Solid red The receiver has power, but it’s not communicating with the 
computer.

Solid green The receiver is receiving power and is communicating successfully 
with Senteo software.

CAUTION
Do not open the receiver or the clicker units to attempt repairs. Refer all service to 
authorized SMART service personnel.

Ready 
Light

Receive 
Light

Transmit 
Light
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Troubleshooting Using the Receiver Lights

Should you experience a problem with your receiver, you can use the Ready light, together with 
the Transmit and Receive lights to troubleshoot it. See page 36 to locate the lights and familiarize 
yourself with their states during normal operation.

Transporting the Senteo Interactive Response System
If you need to ship your Senteo interactive response system, we urge you to repack it with as 
much of the original packaging as possible. If you prefer to use your own packaging materials, 
make sure you adequately protect the product.

Ready Light Transmit Light Receive Light Receiver State
Red, Green, 
Yellow

Green Green Receiver is starting up. Lights flash in 
sequence.

Flashing Green Off Off Receiver is scanning radio channels.
Blinking Green Any state Any state Receiver is accepting commands from 

the computer.
Blinking Red Any state Any state Receiver has rejected a command from 

the computer.
Green Constant flashing 

(approximately 
250 ms)

Blinks when it 
receives data 
from a clicker

Receiver has power and is 
communicating with the computer, but 
isn’t receiving commands.

Yellow Off Off Receiver has power, but communication 
circuits have failed. 

Flashing Red Flashing Flashing Manufacturing tests running, receiver 
isn’t operational. All lights flash together.

Flashing Yellow Any state Any state Receiver software checksum failure.
Flashing Yellow Flashing Flashing Receiver software failure (seen just 

before receiver resets).
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Waste Electrical and Electronic Equipment Regulations

 Waste Electrical and Electronic Equipment regulations apply to all electrical and electronic 
equipment sold within the European Union.

When you dispose of any electrical or electronic equipment, including SMART products, we 
strongly encourage you to contact your local WEEE recycling agency for recycling and disposal 
advice.

Your SMART product required the extraction and use of natural resources for its production. It may 
contain hazardous substances. By disposing of electrical and electronic equipment appropriately, 
you lower the impact of these substances upon health and the environment and reduce the 
pressure on natural resources. Recycling agencies can reuse or recycle most of the materials from 
your product.

Please think about how you intend to dispose of any product that has a WEEE symbol or 
accompanying WEEE guidelines.

If you need more information on the collection, reuse and recycling of electrical and electronic 
equipment, please contact your local WEEE recycling agency.

Alternatively, contact your local reseller or SMART Technologies for information on the 
environmental performance of our products. 
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Customer Support

Online Support
www.smarttech.com/support

Visit the SMART Technologies support site to view and download user’s guides, “how-to” and 
troubleshooting articles, software and more.

Training
Do you need training on your SMART product? Visit http://www.smarttech.com/trainingcenter for 
free training materials and information on our training services.

Contacting SMART Technical Support
SMART’s Technical Support team welcomes your call. However, if you experience difficulties with 
your SMART product, you may want to contact your local reseller first. Your local reseller may be 
able to solve the problem without delay.

All SMART products include free telephone, fax and e-mail support.

Telephone: +1.403.228.5940 or Toll Free 1.866.518.6791 (Canada/U.S.)
(Monday to Friday, 7 a.m. – 6 p.m. Mountain time)

Fax: +1.403.806.1256

E-Mail: support@smarttech.com

Website: www.smarttech.com/support

When you phone Technical Support, it will be helpful if you can access your computer during the 
call. The support representative may ask you for the following information:

• the serial number of your interactive product
• the version of the software that’s causing the problem and the version of your computer’s 

operating system (if applicable)

General Inquiries
Address: SMART Technologies Inc.

1207 – 11 Avenue SW, Suite 300 
Calgary, AB  T3C 0M5
CANADA

Main 1.888.42.SMART (toll-free in Canada/U.S.) or 
Switchboard: +1.403.228.0333 (all other countries)

Fax: +1.403.228.2500

E-Mail: info@smarttech.com
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Warranty
Product warranty is governed by the terms and conditions of SMART’s "Limited Equipment 
Warranty" that shipped with the SMART product at the time of purchase.

Registration
A User Registration card was included with your SMART product. To help us serve you better, fill in 
and mail this card to SMART Technologies Inc. or register online at www.smarttech.com/
registration.

Sending Feedback
You can help us improve our documentation by e-mailing your comments to 
Documentation@smarttech.com.

Obtaining More Information
Visit www.smarttech.com/support to:

– download PDF versions of our user guides, installation instructions and more
– read technical bulletins, FAQs and tips
– troubleshoot a problem
– explore our resource centers to learn about conferencing and room control systems
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